Follow

Which browser versions does Pressly support?

If you ever encounter any issues with the browser, always check to see if you're using a supported browser and version. To see which browser and version you're using, click on this link

By default, if you're using one of the following browsers, you should be updated to the most recent version: 

  • Chrome, 
  • MS Edge, or 
  • Firefox. 

For other browsers such as Safari or Internet Explorer, Pressly supports two versions: the current and one previous version. 

Currently, the supported versioning 

  • For Safari is 9 & 10 
  • For Internet Explorer is 10 & 11. 

In some browsers such as Internet Explorer, you may be viewing Pressly with compatibility mode turned on. This reverts an updated browser to an older version that may not be supported. Try turning compatibility mode off to resolve your issues.

If you are still experiencing issues while using a supported browser version, please contact us at support@pressly.com and we'd be happy to help! 

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

Comments